Plesk autoinstaller GPG error on Ubuntu 14.04 Trusty

Getting error for Plesk auto installer on Ubuntu 12 Trusty:


Reading package lists...
W: GPG error: http://autoinstall.plesk.com trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 227C38D6AF741DEB
W: GPG error: http://autoinstall.plesk.com trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 227C38D6AF741DEB
W: GPG error: http://autoinstall.plesk.com trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 227C38D6AF741DEB
W: GPG error: http://autoinstall.plesk.com trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 227C38D6AF741DEB
W: GPG error: http://autoinstall.plesk.com trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 227C38D6AF741DEB
Gathering information about installed license key...
Checking whether the package dependencies are resolved.
E: Unable to correct problems, you have held broken packages.
---X--- `apt-get` output ---------------------
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
plesk-base : Depends: sw-engine (>= 2.13.9) but it is not going to be installed
plesk-core : Depends: libmyodbc but it is not installable
Depends: pigz but it is not installable
plesk-php56-dba : Depends: libdb5.1 but it is not installable
plesk-php56-imap : Depends: libc-client2007e but it is not installable
plesk-php56-mcrypt : Depends: libmcrypt4 but it is not installable
plesk-service-node-utilities : Depends: libxml-dumper-perl but it is not installable
Depends: sysv-rc-conf but it is not installable
pp12.0.18-bootstrapper : Depends: sw-engine (>= 2.0) but it is not going to be installed
psa-courier-imap : Depends: libdb5.1 but it is not installable
Depends: libssl0.9.8 but it is not installable
psa-php5-configurator : Depends: php5-imap but it is not installable
psa-updates : Depends: sw-engine (>= 2.13.12) but it is not going to be installed

Check following:

1. /etc/apt/sources.list

2. uncomment the deb repos listed as universal/multiverse

3. re-run apt-get update

4. re-run plesk installer

I have also noticed that it tends to give an error about the hostname as well, which I resolved by temporarily setting the hostname to pretty much anything, such as newserver.

Other Information: http://forum.odin.com/threads/plesk-autoinstaller-gpg-error.332686/